[tools] Fix python DeprecationWarning: invalid escape sequence

The python documentation says "it’s highly recommended that you use raw strings for all but the simplest expressions." (https://docs.python.org/3/library/re.html)

So do that with the attached patch generated by

    sed -i -e "s/re.search('/re.search(r'/g" $(git grep -l 're.search(')

The warning can be seen in e.g. python3.7:

    $ python3.7 -Wd
    >>> import re; re.search('\s', '')
    <stdin>:1: DeprecationWarning: invalid escape sequence \s

Commited on behalf of Marco Falke.
Differential Revision: https://reviews.llvm.org/D57528


git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk/tools/scan-build@353707 91177308-0d34-0410-b5e6-96231b3b80d8
1 file changed
tree: a8f359901cfb0c5bff4851a236aadc7a664bd66b
  1. CMakeLists.txt
  2. bin/
  3. libexec/
  4. man/
  5. share/