IWYU: ThemeService requires NativeTheme

As ThemeService referes to NativeTheme through a ScopedObserver,
the full declaration is required.

This is also a good opportunity to remove unneeded includes.

Bug: 819294
Change-Id: I9d5bd2e87cfaa76e87f9b5509daea24848906a63
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1645362
Reviewed-by: Evan Stade <estade@chromium.org>
Commit-Queue: José Dapena Paz <jose.dapena@lge.com>
Cr-Commit-Position: refs/heads/master@{#670980}
2 files changed