Only allow HTTP/0.9 support on default ports.

Also add a group policy to allow HTTP/0.9 support on other
ports, which I plan to remove in a couple revisions.

BUG=624462,637017

Review-Url: https://codereview.chromium.org/2253653002
Cr-Commit-Position: refs/heads/master@{#415643}
24 files changed