[v8] Fix use of deprecated Object::Set in supervised_user_error_page

Uses the context version of Set and checks the return value (which
cannot actually fail in this case but the API requires it).

Bug: v8:7283
Change-Id: Ib22e132cee49da508a00a811f5bd67e4f5903ff2
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1576570
Auto-Submit: Dan Elphick <delphick@chromium.org>
Commit-Queue: Marc Treib <treib@chromium.org>
Reviewed-by: Marc Treib <treib@chromium.org>
Cr-Commit-Position: refs/heads/master@{#653120}
1 file changed