macOS: Update build instructions to reflect new build requirements.

Chrome now requires Xcode 8, macOS 10.12, and 10.12 SDK.

Bug: 669240
Change-Id: I71b0f4238ac3b7baa657bb469480c1a17eaf1e77
Reviewed-on: https://chromium-review.googlesource.com/696291
Reviewed-by: Dirk Pranke <dpranke@chromium.org>
Commit-Queue: Erik Chen <erikchen@chromium.org>
Cr-Commit-Position: refs/heads/master@{#505857}
1 file changed