[v8] Fix use of deprecated Object::Set in renderer

Uses the context version of Set and checks the return value (which
cannot actually fail in this case but the API requires it).

Bug: v8:7283
Change-Id: I1c8b5d0daf846579cb429ef4c71c2a37681a5c46
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1576571
Auto-Submit: Dan Elphick <delphick@chromium.org>
Commit-Queue: Jochen Eisinger <jochen@chromium.org>
Reviewed-by: Jochen Eisinger <jochen@chromium.org>
Cr-Commit-Position: refs/heads/master@{#653124}
2 files changed