s/SPDY/HTTP2/ in net_error_list.h

SPDY has been deprecated years ago and HTTP/2 is widely deployed.
It is time to update net error codes, especially because many of them
can be surfaced to confused users on an error page.

Bug: 345769
Change-Id: I4f5880a73fecbea630c441c08255daef1d7831ca
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1651050
Commit-Queue: Bence Béky <bnc@chromium.org>
Reviewed-by: Ryan Hamilton <rch@chromium.org>
Cr-Commit-Position: refs/heads/master@{#672213}
20 files changed