blob: cc29decea7fe257ecfae987bfa782a147741bbb5 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=6
CROS_WORKON_COMMIT="793b1832780f148a23b5a71a51758d950403874c"
CROS_WORKON_TREE=("88964300c225b7e8a3c2fe47860d091ca1f4fb65" "2654b341562fc7228014b6110e1e2513f7a2353f" "06bff32035e609abf62173acb714075f52f66720" "dc1506ef7c8cfd2c5ffd1809dac05596ec18773c")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk metrics p2p .gn"
PLATFORM_SUBDIR="p2p"
inherit cros-debug cros-workon platform user
DESCRIPTION="Chromium OS P2P"
HOMEPAGE="http://www.chromium.org/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="fuzzer"
RDEPEND="chromeos-base/metrics
dev-libs/glib
net-dns/avahi-daemon
net-firewall/iptables"
DEPEND="${RDEPEND}"
platform_pkg_test() {
local tests=(
p2p-client-unittests
p2p-server-unittests
p2p-http-server-unittests
p2p-common-unittests
)
local test_bin
cd "${OUT}"
for test_bin in "${tests[@]}"; do
platform_test "run" "./${test_bin}"
done
}
pkg_preinst() {
# Groups are managed in the central account database.
enewgroup p2p
enewuser p2p
}
src_install() {
dosbin "${OUT}"/p2p-client
dosbin "${OUT}"/p2p-server
dosbin "${OUT}"/p2p-http-server
insinto /etc/init
doins data/p2p.conf
# Install fuzzer
platform_fuzzer_install "${S}"/OWNERS \
"${OUT}"/p2p_http_server_fuzzer
}