blob: 19f7d37efdb94a48ee7a76f7fd3dc378945c1ce9 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
MY_PN="${PN/-/.}"
MY_PN="${MY_PN//-/_}"
DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/rst-linker[${PYTHON_USEDEP}]
)
test? (
>=dev-python/pytest-2.8[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
)
"
S="${WORKDIR}/${MY_PN}-${PV}"
python_compile_all() {
use doc && esetup.py build_sphinx
}
python_test() {
PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
}
python_install_all() {
use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
distutils-r1_python_install_all
}