blob: a2c43b164175e8617a5f896a7a70d1ff1ec2c2cc [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
CATKIN_HAS_MESSAGES=yes
PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
inherit ros-catkin
DESCRIPTION="Estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/roscpp
dev-ros/tf
dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
sci-libs/orocos-bfl
"
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
virtual/pkgconfig"