blob: f42d5a1d3fe691621c6a89c57afe9bc79f281923 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils games
MY_PV=${PV/./_}
DESCRIPTION="four-dimensional analog of Rubik's cube"
HOMEPAGE="http://www.superliminal.com/cube/cube.htm"
SRC_URI="http://www.superliminal.com/cube/mc4d-src-${MY_PV}.tgz"
LICENSE="free-noncomm"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND="x11-libs/libXaw"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}-src-${MY_PV}
src_prepare() {
epatch "${FILESDIR}"/${PN}-EventHandler.patch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-64bit-ptr.patch \
"${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "s:-Werror::" \
configure \
|| die "sed failed"
}
src_compile() {
emake DFLAGS="${CFLAGS}"
}
src_install() {
dogamesbin magiccube4d
dodoc ChangeLog MagicCube4D-unix.txt readme-unix.txt Intro.txt
prepgamesdirs
}