blob: b343780af50423003cfd908f39808611dd22950b [file] [log] [blame]
# ChangeLog for media-sound/lmms
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.37 2015/03/17 10:53:37 aballier Exp $
*lmms-1.1.3 (17 Mar 2015)
17 Mar 2015; Alexis Ballier <aballier@gentoo.org> +lmms-1.1.3.ebuild:
version bump
*lmms-1.0.3 (29 Jul 2014)
29 Jul 2014; Lars Wendler <polynomial-c@gentoo.org> -lmms-0.4.15.ebuild,
-lmms-1.0.1.ebuild, +lmms-1.0.3.ebuild, -files/lmms-0.4.14-unembedfltk.patch:
Version bump. Removed old.
*lmms-1.0.2 (09 May 2014)
06 May 2014; Lars Wendler <polynomial-c@gentoo.org> -lmms-1.0.0.ebuild,
+lmms-1.0.2.ebuild:
Version bump. Removed old.
*lmms-1.0.1 (05 May 2014)
05 May 2014; Lars Wendler <polynomial-c@gentoo.org> +lmms-1.0.1.ebuild:
Version bump.
28 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> metadata.xml:
Added further info to metadata.
27 Apr 2014; Lars Wendler <polynomial-c@gentoo.org>
-files/lmms-0.4.10-unembedfltk.patch:
Removed old files from FILESDIR.
*lmms-1.0.0 (27 Apr 2014)
27 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> -lmms-0.4.13-r1.ebuild,
-lmms-0.4.14.ebuild, +lmms-1.0.0.ebuild, metadata.xml:
Version bump (bug #505554). Refactored dependencies a bit and added new
co-maintainer and myself as maintainer. Removed old.
*lmms-0.4.15 (27 Jun 2013)
27 Jun 2013; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.15.ebuild:
version bump
19 Jun 2013; Alexis Ballier <aballier@gentoo.org>
files/lmms-0.4.14-unembedfltk.patch:
update the fltk unembedding patch not to require fltk with opengl, bug
#469560 by Daniel Schulte
*lmms-0.4.14 (08 May 2013)
08 May 2013; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.14.ebuild,
+files/lmms-0.4.14-unembedfltk.patch:
version bump, bug #467862
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> lmms-0.4.13-r1.ebuild:
Move Qt dependencies to the new category
*lmms-0.4.13-r1 (30 Jul 2012)
30 Jul 2012; Lars Wendler <polynomial-c@gentoo.org> -lmms-0.4.12.ebuild,
-lmms-0.4.13.ebuild, +lmms-0.4.13-r1.ebuild:
non-maintainer commit: Fixed plugins search path "/usr/usr" (bug #417615).
Removed old version.
*lmms-0.4.13 (14 Feb 2012)
14 Feb 2012; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.13.ebuild:
version bump
09 Jan 2012; Alexis Ballier <aballier@gentoo.org> -lmms-0.4.10.ebuild:
remove old
*lmms-0.4.12 (07 Aug 2011)
07 Aug 2011; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.12.ebuild:
version bump, by Anthony Parsons, bug #378005
26 Apr 2011; Alexis Ballier <aballier@gentoo.org> -lmms-0.4.9.ebuild,
-lmms-0.4.9-r1.ebuild, -lmms-0.4.9-r2.ebuild, -lmms-0.4.9-r3.ebuild,
-files/lmms-unembedfltk.patch:
remove old
*lmms-0.4.10 (03 Apr 2011)
03 Apr 2011; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.10.ebuild,
+files/lmms-0.4.10-unembedfltk.patch:
version bump
20 Mar 2011; Justin Lecher <jlec@gentoo.org> lmms-0.4.9.ebuild,
lmms-0.4.9-r1.ebuild, lmms-0.4.9-r2.ebuild, lmms-0.4.9-r3.ebuild:
x11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly
*lmms-0.4.9-r3 (27 Feb 2011)
27 Feb 2011; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.9-r3.ebuild:
use system ladspa cmt plugins too
*lmms-0.4.9-r2 (26 Feb 2011)
26 Feb 2011; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.9-r2.ebuild:
Do not build ladspa plugins available in the tree, rather rdepend on them
since it can find them.
*lmms-0.4.9-r1 (26 Feb 2011)
26 Feb 2011; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.9-r1.ebuild,
+files/lmms-unembedfltk.patch:
Un-embed fltk for the zynaddsubfx plugin.
02 Jan 2011; Alexis Ballier <aballier@gentoo.org> -lmms-0.4.5.ebuild,
-lmms-0.4.6.ebuild, -lmms-0.4.7.ebuild:
remove old
*lmms-0.4.9 (02 Jan 2011)
02 Jan 2011; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.9.ebuild:
version bump, by Piotr Mrożek (and Jeroen Roovers), bug #339861
*lmms-0.4.7 (15 Aug 2010)
15 Aug 2010; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.7.ebuild:
version bump, thanks to
Lomaxx <thelomaxx@web.de> for the notification
*lmms-0.4.6 (02 Feb 2010)
02 Feb 2010; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.6.ebuild:
version bump, by Nikos Chantziaras <realnc@gmail.com>, bug #301358
06 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> lmms-0.4.5.ebuild:
Removed alternative dependency on Qt metapackage
*lmms-0.4.5 (13 Aug 2009)
13 Aug 2009; Alexis Ballier <aballier@gentoo.org> -lmms-0.4.3.ebuild,
+lmms-0.4.5.ebuild:
version bump, bug #273657
19 Jun 2009; Alexis Ballier <aballier@gentoo.org> -lmms-0.4.2.ebuild:
remove old
09 Mar 2009; Raúl Porcel <armin76@gentoo.org> lmms-0.4.2.ebuild,
lmms-0.4.3.ebuild:
Add ~x86 wrt #260735
*lmms-0.4.3 (27 Feb 2009)
27 Feb 2009; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.3.ebuild:
version bump, by Thomas Kuther <gimpel@sonnenkinder.org>, bug #260520
10 Jan 2009; Alexis Ballier <aballier@gentoo.org>
-lmms-0.4.0_beta2.ebuild, -lmms-0.4.0_rc2.ebuild, -lmms-0.4.0.ebuild:
remove old
*lmms-0.4.2 (10 Jan 2009)
10 Jan 2009; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.2.ebuild:
version bump, thanks Thomas, bug #254369
*lmms-0.4.0 (10 Nov 2008)
10 Nov 2008; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.0.ebuild:
version bump, by Thomas 'gimpel' Kuther, bug #246150
02 Oct 2008; Alexis Ballier <aballier@gentoo.org> lmms-0.4.0_rc2.ebuild:
We need qt4 with the accessibility useflag turned on, bug #239294, fix by
Thomas 'gimpel' Kuther
*lmms-0.4.0_rc2 (23 Sep 2008)
23 Sep 2008; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.0_rc2.ebuild:
Version bump by Paul Giblock <drfaygo@gmail.com>, bug #238247.
*lmms-0.4.0_beta2 (17 Sep 2008)
17 Sep 2008; Alexis Ballier <aballier@gentoo.org> +metadata.xml,
+lmms-0.4.0_beta2.ebuild:
Initial import. Ebuild by Thomas Kuther whom I'm proxying for this
package. Also bug #100170