blob: 75f86144d621362b6e5c4beb16ef493580ae37ef [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
VIRTUALX_REQUIRED="test"
inherit kde5
DESCRIPTION="Framework providing an assortment of configuration-related widgets"
LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm x86"
IUSE="+man"
RDEPEND="
$(add_frameworks_dep kauth)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kwidgetsaddons)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
!<kde-frameworks/kdelibs4support-5.3.0:5
"
DEPEND="${RDEPEND}
man? ( $(add_frameworks_dep kdoctools) )
"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package man KF5DocTools)
)
kde5_src_configure
}