blob: 021813771f635bbe7903e208f84684506b72e95a [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
XORG_DOC=doc
XORG_MULTILIB=yes
inherit xorg-2
DESCRIPTION="X.Org Xi library"
KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE=""
RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
>=x11-proto/inputproto-2.3[${MULTILIB_USEDEP}]
>=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
>=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
src_configure() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable doc specs)
$(use_with doc xmlto)
$(use_with doc asciidoc)
--without-fop
)
xorg-2_src_configure
}