blob: 2dae71a13d16f8c43d4f2ac77d7353a766f073cf [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="xml"
inherit distutils-r1 git-2
DESCRIPTION="Ebuild upstream scan utility"
HOMEPAGE="http://euscan.iksaif.net"
SRC_URI=""
EGIT_REPO_URI="git://github.com/iksaif/euscan.git"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
KEYWORDS=""
DEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
>=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/beautifulsoup[${PYTHON_USEDEP}]"
python_prepare_all() {
python_export_best
echo VERSION="${PV}" "${PYTHON}" setup.py set_version
VERSION="${PV}" "${PYTHON}" setup.py set_version
distutils-r1_python_prepare_all
}