blob: 164eebbecc45526463541821ffcc95a00544de56 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
HOMEPAGE="http://www.xapian.org/"
S="${WORKDIR}/xapian-omega-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
DEPEND="dev-libs/xapian:0/1.2.22
dev-lang/perl
dev-libs/libpcre
sys-libs/zlib"
RDEPEND="${DEPEND}"
src_install () {
emake DESTDIR="${D}" install
# Protect /etc/omega.conf
echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
doenvd "${T}"/20xapian-omega
dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
#move docs to /usr/share/doc/${PF}.
mv "${D}/usr/share/doc/xapian-omega" "${D}/usr/share/doc/${PF}" || die
# Directory containing Xapian databases:
keepdir /var/lib/omega/data
# Directory containing OmegaScript templates:
keepdir /var/lib/omega/templates
mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
# Directory to write Omega logs to:
keepdir /var/log/omega
# Directory containing any cdb files for the $lookup OmegaScript command:
keepdir /var/lib/omega/cdb
}