blob: 174184274cae110a3cb52b3fef576731447b550e [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils toolchain-funcs
[[ ${PV} == 9999* ]] && inherit git-2
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
HOMEPAGE="http://pwmt.org/projects/zathura/"
if ! [[ ${PV} == 9999* ]]; then
SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
fi
EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
if ! [[ ${PV} == 9999* ]]; then
KEYWORDS="amd64 ~arm x86"
else
KEYWORDS=""
fi
IUSE=""
COMMON_DEPEND=">=app-text/zathura-0.2.7
dev-libs/glib:2=
app-arch/libarchive:=
x11-libs/cairo:="
RDEPEND="${COMMON_DEPEND}
app-arch/p7zip
app-arch/tar
app-arch/unrar
app-arch/unzip"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
pkg_setup() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
VERBOSE=1
DESTDIR="${D}"
)
}
src_compile() {
emake "${myzathuraconf[@]}"
}
src_install() {
emake "${myzathuraconf[@]}" install
dodoc AUTHORS
}