blob: 288987a7270f305c449702eeddd34f07c317290e [file] [log] [blame]
# ChangeLog for dev-cpp/antlr-cpp
# Copyright 1999-2016 Gentoo Foundation; Distributed under the GPL v2
# (auto-generated from git log)
*antlr-cpp-2.7.7 (14 Oct 2015)
14 Oct 2015; James Le Cuirot <chewi@gentoo.org> +antlr-cpp-2.7.7.ebuild,
+files/2.7.7-gcc.patch, +files/2.7.7-libtool.patch, +metadata.xml:
New package, split from dev-java/antlr
The old ANTLR 2 ebuild tried to cram all the runtimes together, which
was messy. The C++ runtime does not need any Java components at build
time or runtime so it makes sense to split this out. The C++ runtime
for ANTLR 4 is maintained separately by upstream anyway.
This new package does a better job of building the shared library with
the help of libtool. It also supports multilib.
Package-Manager: portage-2.2.20.1
25 Dec 2015; James Le Cuirot <chewi@gentoo.org> antlr-cpp-2.7.7.ebuild:
Fix src_test breakage, closes bug #569230
There actually aren't any tests but the test target blows up.
Package-Manager: portage-2.2.26
16 Jan 2016; James Le Cuirot <chewi@gentoo.org> antlr-cpp-2.7.7.ebuild:
Add ~arm keyword, closes bug #572028
Package-Manager: portage-2.2.26
17 Jan 2016; Agostino Sarubbo <ago@gentoo.org> antlr-cpp-2.7.7.ebuild:
ppc stable wrt bug #571954
Package-Manager: portage-2.2.26
RepoMan-Options: --include-arches="ppc"
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
23 Jan 2016; Agostino Sarubbo <ago@gentoo.org> antlr-cpp-2.7.7.ebuild:
amd64 stable wrt bug #571954
Package-Manager: portage-2.2.26
RepoMan-Options: --include-arches="amd64"
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
24 Jan 2016; Michał Górny <mgorny@gentoo.org> metadata.xml:
Replace all herds with appropriate projects (GLEP 67)
Replace all uses of herd with appropriate project maintainers, or no
maintainers in case of herds requested to be disbanded.
24 Jan 2016; Michał Górny <mgorny@gentoo.org> metadata.xml:
Set appropriate maintainer types in metadata.xml (GLEP 67)
14 Feb 2016; Agostino Sarubbo <ago@gentoo.org> antlr-cpp-2.7.7.ebuild:
x86 stable wrt bug #571954
Package-Manager: portage-2.2.26
RepoMan-Options: --include-arches="x86"
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
17 Feb 2016; Zero_Chaos <zerochaos@gentoo.org> antlr-cpp-2.7.7.ebuild:
hard block isn't needed, use soft block
Package-Manager: portage-2.2.27