blob: 222194a162dfb066279d6e74ae9b3409403b3e2e [file] [log] [blame]
# ChangeLog for dev-libs/cloog
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/ChangeLog,v 1.34 2015/07/28 12:53:43 blueness Exp $
*cloog-0.18.4 (28 Jul 2015)
28 Jul 2015; Anthony G. Basile <blueness@gentoo.org> +cloog-0.18.4.ebuild,
cloog-9999.ebuild:
Version bump: gmp-6.0.0 and above required. isl-0.15 is bundled, we match
version with the system isl. Patch to avoid use of undocumented isl print
functions committed uptream f38b4fa.
15 Jul 2015; Mike Frysinger <vapier@gentoo.org>
files/cloog-0.18.3-isl-0.15.patch:
Update isl API based on upstream feedback.
15 Jul 2015; Mike Frysinger <vapier@gentoo.org>
+files/cloog-0.18.3-isl-0.15.patch, cloog-0.18.3.ebuild:
Fix building w/isl-0.15.
13 Apr 2015; Agostino Sarubbo <ago@gentoo.org> cloog-0.18.1.ebuild:
Stable for alpha, wrt bug #545124
17 Mar 2015; Mike Frysinger <vapier@gentoo.org> cloog-0.18.0.ebuild,
cloog-0.18.1.ebuild, cloog-0.18.3.ebuild, cloog-9999.ebuild:
Block cloog-ppl as we are punting it #448024.
05 Feb 2015; Anthony G. Basile <blueness@gentoo.org> cloog-0.18.3.ebuild:
Fix FEATURES=test for 0.18.3
*cloog-0.18.3 (05 Feb 2015)
05 Feb 2015; Anthony G. Basile <blueness@gentoo.org> +cloog-0.18.3.ebuild,
cloog-9999.ebuild:
Add 0.18.3 which depends on =dev-libs/isl-0.14:0/14. We skip 0.18.2 doesn't
build against any versions of isl and is skipped in their update log.
26 Dec 2014; Agostino Sarubbo <ago@gentoo.org> cloog-0.18.1.ebuild:
Stable for sparc, wrt bug #516152
04 Nov 2014; Mike Frysinger <vapier@gentoo.org> cloog-0.18.0.ebuild,
cloog-0.18.1.ebuild, cloog-9999.ebuild:
Update HOMEPAGE.
04 Nov 2014; Mike Frysinger <vapier@gentoo.org> cloog-0.18.1.ebuild,
cloog-9999.ebuild:
Add arm64 love.
04 Nov 2014; Mike Frysinger <vapier@gentoo.org> cloog-0.18.1.ebuild:
Mark m68k/s390/sh stable.
03 Nov 2014; Agostino Sarubbo <ago@gentoo.org> cloog-0.18.1.ebuild:
Stable for x86, wrt bug #516152
*cloog-9999 (01 Nov 2014)
01 Nov 2014; Anthony G. Basile <blueness@gentoo.org> +cloog-9999.ebuild:
Add live ebuild for testing
24 Oct 2014; Mikle Kolyada <zlogene@gentoo.org> cloog-0.18.1.ebuild:
amd64 stable wrt bug #516152
22 Oct 2014; Anthony G. Basile <blueness@gentoo.org> cloog-0.18.1.ebuild:
Stable on ppc and ppc64, bug #516152
22 Oct 2014; Markus Meier <maekke@gentoo.org> cloog-0.18.1.ebuild:
arm stable, bug #516152
24 Sep 2014; Anthony G. Basile <blueness@gentoo.org> cloog-0.18.0.ebuild,
cloog-0.18.1.ebuild:
Keyword ~ppc ~ppc64
05 Aug 2014; Raúl Porcel <armin76@gentoo.org> cloog-0.18.0.ebuild,
cloog-0.18.1.ebuild:
Add ~m68k/~s390/~sh/~sparc wrt #487266
22 Jun 2014; Akinori Hattori <hattya@gentoo.org> cloog-0.18.0.ebuild,
cloog-0.18.1.ebuild:
keyword ~ia64 wrt bug #487266
18 Jun 2014; Michał Górny <mgorny@gentoo.org> cloog-0.18.1.ebuild:
Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
#513718.
*cloog-0.18.1 (22 May 2014)
22 May 2014; Ryan Hill <rhill@gentoo.org> -cloog-0.17.0.ebuild,
cloog-0.18.0.ebuild, +cloog-0.18.1.ebuild:
Version bump (bug #491726). USE EAPI 5 and subslots. Add multilib support.
Add missing pkgconfig dep. Remove old.
04 Nov 2013; Matt Turner <mattst88@gentoo.org> cloog-0.18.0.ebuild:
Added ~alpha, bug 487266.
14 Oct 2013; Naohiro Aota <naota@gentoo.org> cloog-0.18.0.ebuild:
Add ~x86-fbsd. #487266
12 Oct 2013; Markus Meier <maekke@gentoo.org> cloog-0.18.0.ebuild:
add ~arm, bug #487266
12 Oct 2013; Alexis Ballier <aballier@gentoo.org> cloog-0.18.0.ebuild:
keyword ~amd64-fbsd, bug #487266
11 Oct 2013; Markos Chandras <hwoarang@gentoo.org> cloog-0.18.0.ebuild:
Add ~mips per #487266
09 Oct 2013; Jeroen Roovers <jer@gentoo.org> cloog-0.18.0.ebuild:
Marked ~hppa (bug #487266).
*cloog-0.18.0 (07 Jan 2013)
07 Jan 2013; Ryan Hill <dirtyepic@gentoo.org> +cloog-0.18.0.ebuild:
Version bump (bug #450628). Stop using autotools-utils - we want to avoid
autoreconf in this package. Steal the pkgconfig trick from isl until
upstream updates their ax_create_pkgconfig_info.m4 to ignore LDFLAGS.
07 Jan 2013; Ryan Hill <dirtyepic@gentoo.org> cloog-0.17.0.ebuild:
Restrict isl to older versions.
27 Jun 2012; Ryan Hill <dirtyepic@gentoo.org> -cloog-0.16.3.ebuild:
Remove old.
*cloog-0.17.0 (20 Feb 2012)
20 Feb 2012; Ryan Hill <dirtyepic@gentoo.org> -cloog-0.16.1.ebuild,
-cloog-0.16.2.ebuild, cloog-0.16.3.ebuild, +cloog-0.17.0.ebuild:
Version bump.
*cloog-0.16.3 (21 Aug 2011)
21 Aug 2011; Ryan Hill <dirtyepic@gentoo.org> +cloog-0.16.3.ebuild:
Version bump.
*cloog-0.16.2 (14 Apr 2011)
14 Apr 2011; Ryan Hill <dirtyepic@gentoo.org> +cloog-0.16.2.ebuild:
Version bump.
*cloog-0.16.1 (08 Jan 2011)
08 Jan 2011; Ryan Hill <dirtyepic@gentoo.org> +cloog-0.16.1.ebuild,
+metadata.xml:
Initial import.