blob: 758438090bab316586ca7335d906e6d3358676c4 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools games
DESCRIPTION="A space rock shooting video game"
HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/cosmosmash.html"
SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
RESTRICT="test" # uses the sound card which portage user might not be available.
RDEPEND=">=dev-games/flatzebra-0.1.6"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
sed -i \
-e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
-e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
-e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
src/Makefile.am \
|| die
eautoreconf
}
src_install() {
emake -C src DESTDIR="${D}" install
doman doc/${PN}.6
dodoc AUTHORS NEWS README THANKS
prepgamesdirs
}