blob: 7c14f47bb26f1d11081e0b063794bc5fb9f71f5a [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="200311-01">
<title>kdebase: KDM vulnerabilities</title>
A bug in KDM can allow privilege escalation with certain configurations of
PAM modules.
<product type="ebuild">kdebase</product>
<revised>2003-11-15: 01</revised>
<access>local / remote</access>
<package name="kde-base/kdebase" auto="yes" arch="*">
<unaffected range="ge">3.1.4</unaffected>
<vulnerable range="le">3.1.3</vulnerable>
KDM is the desktop manager included with the K Desktop Environment.
Firstly, versions of KDM &lt;=3.1.3 are vulnerable to a privilege escalation
bug with a specific configuration of PAM modules. Users who do not use PAM
with KDM and users who use PAM with regular Unix crypt/MD5 based
authentication methods are not affected.
Secondly, KDM uses a weak cookie generation algorithm. Users are advised to
upgrade to KDE 3.1.4, which uses /dev/urandom as a non-predictable source of
entropy to improve security.
<impact type="normal">
A remote or local attacker could gain root privileges.
There is no known workaround at this time.
It is recommended that all Gentoo Linux users who are running
kde-base/kdebase &lt;=3.1.3 upgrade:
# emerge sync
# emerge -pv '&gt;=kde-base/kde-3.1.4'
# emerge '&gt;=kde-base/kde-3.1.4'
# emerge clean</code>
<uri link="">CAN-2003-0690</uri>
<uri link="">CAN-2003-0692</uri>
<uri link="">KDE Security Advisory</uri>