blob: dbe2dc2bce73640faac170c50260d2954f0b4e9a [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="200312-08">
<title>CVS: possible root compromise when using CVS pserver</title>
A possible root compromise exists for CVS pservers.
<product type="ebuild">cvs</product>
<revised>2003-12-28: 01</revised>
<package name="dev-util/cvs" auto="yes" arch="*">
<unaffected range="ge">1.11.11</unaffected>
<vulnerable range="le">1.11.10</vulnerable>
CVS, which stands for Concurrent Versions System, is a client/server
application which tracks changes to sets of files. It allows multiple users
to work concurrently on files, and then merge their changes back into the
main tree (which can be on a remote system). It also allows branching, or
maintaining separate versions for files.
Quote from
"Stable CVS 1.11.11 has been released. Stable releases contain only bug
fixes from previous versions of CVS. This release adds code to the CVS
server to prevent it from continuing as root after a user login, as an extra
failsafe against a compromise of the CVSROOT/passwd file. Previously, any
user with the ability to write the CVSROOT/passwd file could execute
arbitrary code as the root user on systems with CVS pserver access enabled.
We recommend this upgrade for all CVS servers!"
<impact type="high">
A remote user could execute arbitrary code with the permissions of the root
There is no known workaround at this time.
All Gentoo Linux machines with cvs installed should be updated to use
cvs-1.11.11 or higher.
# emerge sync
# emerge -pv '&gt;=dev-util/cvs-1.11.11'
# emerge '&gt;=dev-util/cvs-1.11.11'
# emerge clean</code>