blob: e369a8134f319024db61a05edbc218af5c2eb313 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200401-03">
<title>Apache mod_python Denial of Service vulnerability</title>
Apache's mod_python module could crash the httpd process if a specific,
malformed query string was sent.
<product type="ebuild">mod_python</product>
<announced>January 27, 2004</announced>
<revised>December 30, 2007: 02</revised>
<package name="www-apache/mod_python" auto="yes" arch="*">
<unaffected range="ge">2.7.10</unaffected>
<vulnerable range="lt">2.7.10</vulnerable>
Mod_python is an Apache module that embeds the Python interpreter
within the server allowing Python-based web-applications to be
The Apache Foundation has reported that mod_python may be prone to
Denial of Service attacks when handling a malformed
query. Mod_python 2.7.9 was released to fix the vulnerability,
however, because the vulnerability has not been fully fixed,
version 2.7.10 has been released.
Users of mod_python 3.0.4 are not affected by this vulnerability.
<impact type="low">
Although there are no known public exploits known for this
exploit, users are recommended to upgrade mod_python to ensure the
security of their infrastructure.
Mod_python 2.7.10 has been released to solve this issue; there is
no immediate workaround.
All users using mod_python 2.7.9 or below are recommended to
update their mod_python installation:
$> emerge sync
$> emerge -pv ">=www-apache/mod_python-2.7.10"
$> emerge ">=www-apache/mod_python-2.7.10"
$> /etc/init.d/apache restart</code>
<uri link="">Mod_python 2.7.10 release announcement</uri>