blob: 379f664dc4b50e59faea2c516ae4d0159b19ad53 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200402-04">
<title>Gallery 1.4.1 and below remote exploit vulnerability</title>
The Gallery developers have discovered a potentially serious security flaw
in Gallery 1.3.1, 1.3.2, 1.3.3, 1.4 and 1.4.1 which can allow a
remote exploit of your webserver.
<product type="ebuild">Gallery</product>
<announced>February 11, 2004</announced>
<revised>February 11, 2004: 01</revised>
<package name="www-apps/gallery" auto="yes" arch="*">
<unaffected range="ge">1.4.1_p1</unaffected>
<vulnerable range="lt">1.4.1_p1</vulnerable>
Gallery is an open source image management system written in PHP.
More information is available at
Starting in the 1.3.1 release, Gallery includes code to simulate the behaviour
of the PHP 'register_globals' variable in environments where that setting
is disabled. It is simulated by extracting the values of the various
$HTTP_ global variables into the global namespace.
<impact type="normal">
A crafted URL such as causes the
'register_globals' simulation code to overwrite the $HTTP_POST_VARS which,
when it is extracted, will deliver the given payload. If the
payload compromises $GALLERY_BASEDIR then the malicious user can perform a
PHP injection exploit and gain remote access to the webserver with PHP
user UID access rights.
The workaround for the vulnerability is to replace init.php and
setup/init.php with the files in the following ZIP file:
All users are encouraged to upgrade their gallery installation:
# emerge sync
# emerge -p ">=www-apps/gallery-1.4.1_p1"
# emerge ">=www-apps/gallery-1.4.1_p1"</code>