blob: cf5005ed0f51c8d96ec71efbc7c87eb93e8c551b [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200402-05">
<title>phpMyAdmin &lt; 2.5.6-rc1: possible attack against export.php</title>
A vulnerability in phpMyAdmin which was not properly verifying user
generated input could lead to a directory traversal attack.
<product type="ebuild">phpmyadmin</product>
<announced>February 17, 2004</announced>
<revised>February 17, 2004: 01</revised>
<package name="dev-db/phpmyadmin" auto="yes" arch="*">
<unaffected range="ge">2.5.6_rc1</unaffected>
<vulnerable range="le">2.5.5_p1</vulnerable>
phpMyAdmin is a tool written in PHP intended to handle the administration
of MySQL databased over the Web.
One component of the phpMyAdmin software package (export.php) does not
properly verify input that is passed to it from a remote user. Since the
input is used to include other files, it is possible to launch a directory
traversal attack.
<impact type="normal">
Private information could be gleaned from the remote server if an attacker
uses a malformed URL such as[existing_file]
In this scenario, the script does not sanitize the "what" argument passed
to it, allowing directory traversal attacks to take place, disclosing
the contents of files if the file is readable as the web-server user.
The workaround is to either patch the export.php file using the
referenced CVS patch or upgrade the software via Portage.
Users are encouraged to upgrade to phpMyAdmin-2.5.6_rc1:
# emerge sync
# emerge -pv ">=dev-db/phpmyadmin-2.5.6_rc1"
# emerge ">=dev-db/phpmyadmin-2.5.6_rc1"
# emerge clean</code>
<uri link=";r2=">CVS Patch</uri>