blob: 73d1614d72314723a4fc3d644091c70958438a4d [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200404-02">
<title>KDE Personal Information Management Suite Remote Buffer Overflow Vulnerability</title>
KDE-PIM may be vulnerable to a remote buffer overflow attack that may allow
unauthorized access to an affected system.
<product type="ebuild">kde-base/kde</product>
<announced>April 06, 2004</announced>
<revised>April 06, 2004: 01</revised>
<package name="kde-base/kde" auto="yes" arch="*">
<unaffected range="ge">3.1.5</unaffected>
<vulnerable range="le">3.1.4</vulnerable>
KDE-PIM is an application suite designed to manage mail, addresses,
appointments, and contacts.
A buffer overflow may occur in KDE-PIM's VCF file reader when a maliciously
crafted VCF file is opened by a user on a vulnerable system.
<impact type="high">
A remote attacker may unauthorized access to a user's personal data or
execute commands with the user's privileges.
A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.
KDE users should upgrade to version 3.1.5 or later:
# emerge sync
# emerge -pv ">=kde-base/kde-3.1.5"
# emerge ">=kde-base/kde-3.1.5"</code>
<uri link="">CAN-2003-0988</uri>
<metadata tag="submitter">aescriva</metadata>