blob: 7804015e7e6a856f5d85ec8f151b572a458bf16f [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200404-06">
<title>Util-linux login may leak sensitive data</title>
The login program included in util-linux could leak sensitive information
under certain conditions.
<product type="ebuild"> </product>
<announced>April 07, 2004</announced>
<revised>April 07, 2004: 01</revised>
<package name="sys-apps/util-linux" auto="yes" arch="*">
<unaffected range="ge">2.12</unaffected>
<vulnerable range="le">2.11</vulnerable>
Util-linux is a suite of essential system utilites, including login,
agetty, fdisk.
In some situations the login program could leak sensitive data due to an
incorrect usage of a reallocated pointer.
<b>NOTE:</b> Only users who have PAM support <b>disabled</b> on their
systems (i.e. <i>-PAM</i> in their USE variable) will be affected by this
vulnerability. By default, this USE flag is <b>enabled</b> on all
architectures. Users with PAM support on their system receive login binaries
as part of the pam-login package, which remains unaffected.
<impact type="low">
A remote attacker may obtain sensitive data.
A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.
All util-linux users should upgrade to version 2.12 or later:
# emerge sync
# emerge -pv ">=sys-apps/util-linux-2.12"
# emerge ">=sys-apps/util-linux-2.12"
<uri link="">CAN-2004-0080</uri>
<metadata tag="submitter">lcars</metadata>