blob: 9d92dbab1b0678ec50cf4549a3d950b36cede13e [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200404-15">
<title>XChat 2.0.x SOCKS5 Vulnerability</title>
XChat is vulnerable to a stack overflow that may allow a remote attacker to
run arbitrary code.
<product type="ebuild">xchat</product>
<announced>April 19, 2004</announced>
<revised>May 22, 2006: 02</revised>
<package name="net-irc/xchat" auto="yes" arch="*">
<unaffected range="ge">2.0.8-r1</unaffected>
<vulnerable range="lt">2.0.8-r1</vulnerable>
XChat is a multiplatform IRC client.
The SOCKS 5 proxy code in XChat is vulnerable to a remote exploit.
Users would have to be using XChat through a SOCKS 5 server, enable
SOCKS 5 traversal which is disabled by default and also connect to an
attacker's custom proxy server.
<impact type="low">
This vulnerability may allow an attacker to run arbitrary code within
the context of the user ID of the XChat client.
A workaround is not currently known for this issue. All users are
advised to upgrade to the latest version of the affected package.
All XChat users should upgrade to the latest stable version:
# emerge sync
# emerge -pv &quot;&gt;=net-irc/xchat-2.0.8-r1&quot;
# emerge &quot;&gt;=net-irc/xchat-2.0.8-r1&quot;</code>
Note that users of the gtk1 version of xchat (1.8.*) should upgrade to
# emerge sync
# emerge -pv &quot;=net-irc/xchat-1.8.11-r1&quot;
# emerge &quot;=net-irc/xchat-1.8.11-r1&quot;</code>
<uri link="">XChat 2.0.x SOCKS5 Vulnerability</uri>
<uri link="">CVE-2004-0409</uri>
<metadata tag="submitter">