blob: 39357bad567ac7c6e2f3ba2d82f56e1686dfb3bc [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200404-16">
<title>Multiple new security vulnerabilities in monit</title>
<synopsis>
Two new vulnerabilities have been found in the HTTP interface of monit,
possibly leading to denial of service or execution of arbitrary code.
</synopsis>
<product type="ebuild">monit</product>
<announced>April 19, 2004</announced>
<revised>April 19, 2004: 01</revised>
<bug>47631</bug>
<access>remote </access>
<affected>
<package name="app-admin/monit" auto="yes" arch="*">
<unaffected range="ge">4.2.1</unaffected>
<vulnerable range="le">4.2</vulnerable>
</package>
</affected>
<background>
<p>
Monit is a system administration utility that allows management and
monitoring of processes, files, directories and devices on a Unix system.
</p>
</background>
<description>
<p>
Monit has several vulnerabilities in its HTTP interface : a buffer overflow
vulnerability in the authentication handling code and a off-by-one error in
the POST method handling code.
</p>
</description>
<impact type="high">
<p>
An attacker may exploit the off-by-one error to crash the Monit daemon and
create a denial of service condition, or cause a buffer overflow that would
allow arbitrary code to be executed with root privileges.
</p>
</impact>
<workaround>
<p>
A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.
</p>
</workaround>
<resolution>
<p>
Monit users should upgrade to version 4.2.1 or later:
</p>
<code>
# emerge sync
# emerge -pv ">=app-admin/monit-4.2.1"
# emerge ">=app-admin/monit-4.2.1"</code>
</resolution>
<references>
<uri link="http://www.tildeslash.com/monit/secadv_20040305.txt">Monit security advisory 20040305</uri>
</references>
<metadata tag="submitter">
koon
</metadata>
</glsa>