blob: 39357bad567ac7c6e2f3ba2d82f56e1686dfb3bc [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200404-16">
<title>Multiple new security vulnerabilities in monit</title>
Two new vulnerabilities have been found in the HTTP interface of monit,
possibly leading to denial of service or execution of arbitrary code.
<product type="ebuild">monit</product>
<announced>April 19, 2004</announced>
<revised>April 19, 2004: 01</revised>
<access>remote </access>
<package name="app-admin/monit" auto="yes" arch="*">
<unaffected range="ge">4.2.1</unaffected>
<vulnerable range="le">4.2</vulnerable>
Monit is a system administration utility that allows management and
monitoring of processes, files, directories and devices on a Unix system.
Monit has several vulnerabilities in its HTTP interface : a buffer overflow
vulnerability in the authentication handling code and a off-by-one error in
the POST method handling code.
<impact type="high">
An attacker may exploit the off-by-one error to crash the Monit daemon and
create a denial of service condition, or cause a buffer overflow that would
allow arbitrary code to be executed with root privileges.
A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.
Monit users should upgrade to version 4.2.1 or later:
# emerge sync
# emerge -pv ">=app-admin/monit-4.2.1"
# emerge ">=app-admin/monit-4.2.1"</code>
<uri link="">Monit security advisory 20040305</uri>
<metadata tag="submitter">