blob: 271476dfd3e2bcb46cc50ec76bb3b14f80733f24 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200405-11">
<title>KDE URI Handler Vulnerabilities</title>
Vulnerabilities in KDE URI handlers makes your system vulnerable to various
<product type="ebuild">kdelibs</product>
<announced>May 19, 2004</announced>
<revised>May 19, 2004: 01</revised>
<access>remote </access>
<package name="kde-base/kdelibs" auto="yes" arch="*">
<unaffected range="ge">3.2.2-r1</unaffected>
<unaffected range="eq">3.1.5-r1</unaffected>
<vulnerable range="le">3.2.2</vulnerable>
The K Desktop Environment (KDE) is a powerful Free Software graphical
desktop environment. KDE makes use of URI handlers to trigger various
programs when specific URLs are received.
The telnet, rlogin, ssh and mailto URI handlers in KDE do not check for '-'
at the beginning of the hostname passed. By crafting a malicious URI and
entice an user to click on it, it is possible to pass an option to the
programs started by the handlers (typically telnet, kmail...).
<impact type="normal">
If the attacker controls the options passed to the URI handling programs,
it becomes possible for example to overwrite arbitrary files (possibly
leading to denial of service), to open kmail on an attacker-controlled
remote display or with an alternate configuration file (possibly leading to
control of the user account).
There is no known workaround at this time. All users are advised to upgrade
to a corrected version of kdelibs.
Users of KDE 3.1 should upgrade to the corrected version of kdelibs:
# emerge sync
# emerge -pv "=kde-base/kdelibs-3.1.5-r1"
# emerge "=kde-base/kdelibs-3.1.5-r1"</code>
Users of KDE 3.2 should upgrade to the latest available version of kdelibs:
# emerge sync
# emerge -pv ">=kde-base/kdelibs-3.2.2-r1"
# emerge ">=kde-base/kdelibs-3.2.2-r1"</code>
<uri link="">CAN-2004-0411</uri>
<metadata tag="submitter">