blob: 1ed75d9724c67a4961a55f7b7cd174629e78e0fb [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200405-12">
<title>CVS heap overflow vulnerability</title>
CVS is subject to a heap overflow vulnerability allowing source repository
<product type="ebuild">cvs</product>
<announced>May 20, 2004</announced>
<revised>May 20, 2004: 01</revised>
<access>remote </access>
<package name="dev-util/cvs" auto="yes" arch="*">
<unaffected range="ge">1.11.16</unaffected>
<vulnerable range="le">1.11.15</vulnerable>
CVS (Concurrent Versions System) is an open-source network-transparent
version control system. It contains both a client utility and a server.
Stefan Esser discovered a heap overflow in the CVS server, which can be
triggered by sending malicious "Entry" lines and manipulating the flags
related to that Entry. This vulnerability was proven to be exploitable.
<impact type="high">
A remote attacker can execute arbitrary code on the CVS server, with the
rights of the CVS server. By default, Gentoo uses the "cvs" user to run the
CVS server. In particular, this flaw allows a complete compromise of CVS
source repositories. If you're not running a server, then you are not
There is no known workaround at this time. All users are advised to upgrade
to the latest available version of CVS.
All users running a CVS server should upgrade to the latest stable version:
# emerge sync
# emerge -pv ">=dev-util/cvs-1.11.16"
# emerge ">=dev-util/cvs-1.11.16"</code>
<uri link="">E-matters advisory 07/2004</uri>
<uri link="">CAN-2004-0396</uri>
<metadata tag="submitter">