blob: 2d3664224af206a56f6c78aafaa9e269bab2b9ca [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200406-01">
<title>Ethereal: Multiple security problems</title>
Multiple vulnerabilities including one buffer overflow exist in Ethereal,
which may allow an attacker to run arbitrary code or crash the program.
<product type="ebuild">Ethereal</product>
<announced>June 04, 2004</announced>
<revised>May 22, 2006: 02</revised>
<package name="net-analyzer/ethereal" auto="yes" arch="*">
<unaffected range="ge">0.10.4</unaffected>
<vulnerable range="le">0.10.3</vulnerable>
Ethereal is a feature rich network protocol analyzer.
There are multiple vulnerabilities in versions of Ethereal earlier than
0.10.4, including:
<li>A buffer overflow in the MMSE dissector.</li>
<li>Under specific conditions a SIP packet could make Ethereal
<li>The AIM dissector could throw an assertion, causing Ethereal to
<li>The SPNEGO dissector could dereference a null pointer, causing a
<impact type="high">
An attacker could use these vulnerabilities to crash Ethereal or even
execute arbitrary code with the permissions of the user running
Ethereal, which could be the root user.
For a temporary workaround you can disable all affected protocol
dissectors by selecting Analyze->Enabled Protocols... and deselecting
them from the list. However, it is strongly recommended to upgrade to
the latest stable release.
All Ethereal users should upgrade to the latest stable version:
# emerge sync
# emerge -pv &quot;&gt;=net-analyzer/ethereal-0.10.4&quot;
# emerge &quot;&gt;=net-analyzer/ethereal-0.10.4&quot;</code>
<uri link="">Ethereal enpa-sa-00014</uri>
<uri link="">CVE-2004-0504</uri>
<uri link="">CVE-2004-0505</uri>
<uri link="">CVE-2004-0506</uri>
<uri link="">CVE-2004-0507</uri>
<metadata tag="submitter">