blob: bb2d802e15fa4710b54c54b5f45815581404203e [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200406-06">
<title>CVS: additional DoS and arbitrary code execution vulnerabilities</title>
Several serious new vulnerabilities have been found in CVS, which may allow
an attacker to remotely compromise a CVS server.
<product type="ebuild">CVS</product>
<announced>June 10, 2004</announced>
<revised>June 10, 2004: 01</revised>
<package name="dev-util/cvs" auto="yes" arch="*">
<unaffected range="ge">1.11.17</unaffected>
<vulnerable range="le">1.11.16-r1</vulnerable>
CVS (Concurrent Versions System) is an open-source network-transparent
version control system. It contains both a client utility and a server.
A team audit of the CVS source code performed by Stefan Esser and Sebastian
Krahmer resulted in the discovery of several remotely exploitable
vulnerabilities including:
<li>no-null-termination of &quot;Entry&quot; lines</li>
<li>error_prog_name &quot;double-free()&quot;</li>
<li>Argument integer overflow</li>
<li>serve_notify() out of bounds writes</li>
<impact type="high">
An attacker could use these vulnerabilities to cause a Denial of Service or
execute arbitrary code with the permissions of the user running cvs.
There is no known workaround at this time. All users are advised to upgrade
to the latest available version of CVS.
All CVS users should upgrade to the latest stable version:
# emerge sync
# emerge -pv ">=dev-util/cvs-1.11.17"
# emerge ">=dev-util/cvs-1.11.17"</code>
<uri link="">E-matters Advisory 09/2004</uri>
<uri link="">CAN-2004-0414</uri>
<uri link="">CAN-2004-0416</uri>
<uri link="">CAN-2004-0417</uri>
<uri link="">CAN-2004-0418</uri>
<metadata tag="submitter">