blob: f24263dab9d35f743119b7bde91ffe6b64b3a137 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200406-11">
<title>Horde-IMP: Input validation vulnerability</title>
An input validation vulnerability has been discovered in Horde-IMP.
<product type="ebuild">horde-imp</product>
<announced>June 16, 2004</announced>
<revised>May 22, 2006: 02</revised>
<package name="www-apps/horde-imp" auto="yes" arch="*">
<unaffected range="ge">3.2.4</unaffected>
<vulnerable range="le">3.2.3</vulnerable>
Horde-IMP is the Internet Messaging Program. It is written in PHP and
provides webmail access to IMAP and POP3 accounts.
Horde-IMP fails to properly sanitize email messages that contain
malicious HTML or script code.
<impact type="normal">
By enticing a user to read a specially crafted e-mail, an attacker can
execute arbitrary scripts running in the context of the victim's
browser. This could lead to a compromise of the user's webmail account,
cookie theft, etc.
There is no known workaround at this time.
All Horde-IMP users should upgrade to the latest stable version:
# emerge sync
# emerge -pv &quot;&gt;=www-apps/horde-imp-3.2.4&quot;
# emerge &quot;&gt;=www-apps/horde-imp-3.2.4&quot;</code>
<uri link="">Bugtraq Announcement</uri>
<uri link="">CVE-2004-0584</uri>
<metadata tag="submitter">