blob: e312b16419dad3a895697c8a8d9f5533d5b3ca4b [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200406-16">
<title>Apache 1.3: Buffer overflow in mod_proxy</title>
A bug in mod_proxy may allow a remote attacker to execute arbitrary code
when Apache is configured a certain way.
<product type="ebuild">Apache</product>
<announced>June 21, 2004</announced>
<revised>December 30, 2007: 02</revised>
<package name="www-servers/apache" auto="yes" arch="*">
<unaffected range="ge">1.3.31-r2</unaffected>
<vulnerable range="le">1.3.31-r1</vulnerable>
The Apache HTTP Server Project is an effort to develop and maintain an
open-source HTTP server for modern operating systems. The goal of this
project is to provide a secure, efficient and extensible server that
provides services in tune with the current HTTP standards.
A bug in the proxy_util.c file may lead to a remote buffer overflow. To
trigger the vulnerability an attacker would have to get mod_proxy to
connect to a malicous server which returns an invalid (negative)
<impact type="normal">
An attacker could cause a Denial of Service as the Apache child handling
the request, which will die and under some circumstances execute arbitrary
code as the user running Apache, usually &quot;apache&quot;.
There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version:
Apache 1.x users should upgrade to the latest version of Apache:
# emerge sync
# emerge -pv ">=www-servers/apache-1.3.31-r2"
# emerge ">=www-servers/apache-1.3.31-r2"</code>
<uri link="">Georgi Guninski security advisory #69, 2004</uri>
<uri link="">CAN-2004-0492</uri>
<metadata tag="submitter">