blob: b7e4e740e74a7b4f60701614893e1eb9fcf8bc46 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200407-18">
<title>mod_ssl: Format string vulnerability</title>
A bug in mod_ssl may allow a remote attacker to execute arbitrary code when
Apache is configured to use mod_ssl and mod_proxy.
<product type="ebuild">mod_ssl</product>
<announced>July 22, 2004</announced>
<revised>July 22, 2004: 01</revised>
<package name="net-www/mod_ssl" auto="yes" arch="*">
<unaffected range="ge">2.8.19</unaffected>
<vulnerable range="le">2.8.18</vulnerable>
mod_ssl provides Secure Sockets Layer encryption and authentication to
Apache 1.3.
A bug in ssl_engine_ext.c makes mod_ssl vulnerable to a ssl_log() related
format string vulnerability in the mod_proxy hook functions.
<impact type="normal">
Given the right server configuration, an attacker could execute code as the
user running Apache, usually &quot;apache&quot;.
A server should not be vulnerable if it is not using both mod_ssl and
mod_proxy. Otherwise there is no workaround other than to disable mod_ssl.
All mod_ssl users should upgrade to the latest version:
# emerge sync
# emerge -pv ">=net-www/mod_ssl-2.8.19"
# emerge ">=net-www/mod_ssl-2.8.19"</code>
<uri link=";m=109001100906749&amp;w=2">mod_ssl Announcement</uri>
<metadata tag="submitter">