blob: e53ced251d2d210d1007407bc23468c5edb4d7b1 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200408-07">
<title>Horde-IMP: Input validation vulnerability for Internet Explorer users</title>
An input validation vulnerability has been discovered in Horde-IMP. This
only affects users of Internet Explorer.
<product type="ebuild">horde-imp</product>
<announced>August 10, 2004</announced>
<revised>May 22, 2006: 02</revised>
<package name="www-apps/horde-imp" auto="yes" arch="*">
<unaffected range="ge">3.2.5</unaffected>
<vulnerable range="le">3.2.4</vulnerable>
Horde-IMP is the Internet Messaging Program. It is written in PHP and
provides webmail access to IMAP and POP3 accounts.
Horde-IMP fails to properly sanitize email messages that contain
malicious HTML or script code so that it is not safe for users of
Internet Explorer when using the inline MIME viewer for HTML messages.
<impact type="normal">
By enticing a user to read a specially crafted e-mail, an attacker can
execute arbitrary scripts running in the context of the victim's
browser. This could lead to a compromise of the user's webmail account,
cookie theft, etc.
Do not use Internet Explorer to access Horde-IMP.
All Horde-IMP users should upgrade to the latest stable version:
# emerge sync
# emerge -pv &quot;&gt;=www-apps/horde-imp-3.2.5&quot;
# emerge &quot;&gt;=www-apps/horde-imp-3.2.5&quot;</code>
<uri link=";r2=1.389.2.109&amp;ty=h">Horde-IMP Changelog</uri>
<uri link="">Secunia Advisory SA12202</uri>
<uri link="">CVE-2004-1443</uri>
<metadata tag="submitter" timestamp="Sun, 8 Aug 2004 18:55:04 +0000">