blob: 013868c676717d95627b044d4a21a1240e82075f [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200408-08">
<title>Cfengine: RSA Authentication Heap Corruption</title>
Cfengine is vulnerable to a remote root exploit from clients in
<product type="ebuild">Cfengine</product>
<announced>August 10, 2004</announced>
<revised>May 22, 2006: 05</revised>
<package name="net-misc/cfengine" auto="yes" arch="*">
<unaffected range="ge">2.1.8</unaffected>
<unaffected range="lt">2.0.0</unaffected>
<vulnerable range="le">2.1.7</vulnerable>
Cfengine is an agent/software robot and a high level policy language
for building expert systems to administrate and configure large
computer networks.
Two vulnerabilities have been found in cfservd. One is a buffer
overflow in the AuthenticationDialogue function and the other is a
failure to check the proper return value of the ReceiveTransaction
<impact type="high">
An attacker could use the buffer overflow to execute arbitrary code
with the permissions of the user running cfservd, which is usually the
root user. However, before such an attack could be mounted, the
IP-based ACL would have to be bypassed. With the second vulnerability,
an attacker could cause a denial of service attack.
There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Cfengine. (It should be
noted that disabling cfservd will work around this particular problem.
However, in many cases, doing so will cripple your Cfengine setup.
Upgrading is strongly recommended.)
All Cfengine users should upgrade to the latest version:
# emerge sync
# emerge -pv &quot;&gt;=net-misc/cfengine-2.1.8&quot;
# emerge &quot;&gt;=net-misc/cfengine-2.1.8&quot;</code>
<uri link=";idxseccion=10">Corelabs Advisory</uri>
<uri link="">CVE-2004-1701</uri>
<uri link="">CVE-2004-1702</uri>
<metadata tag="submitter" timestamp="Mon, 9 Aug 2004 21:29:04 +0000">