blob: c95a139d41f76c3f0122b7bd006c2cab4f0f8d1e [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200408-26">
<title>zlib: Denial of service vulnerability</title>
<synopsis>
The zlib library contains a Denial of Service vulnerability.
</synopsis>
<product type="ebuild">zlib</product>
<announced>August 27, 2004</announced>
<revised>May 22, 2006: 02</revised>
<bug>61749</bug>
<access>remote</access>
<affected>
<package name="sys-libs/zlib" auto="yes" arch="*">
<unaffected range="ge">1.2.1-r3</unaffected>
<vulnerable range="le">1.2.1-r2</vulnerable>
</package>
</affected>
<background>
<p>
zlib is a general-purpose data-compression library.
</p>
</background>
<description>
<p>
zlib contains a bug in the handling of errors in the "inflate()" and
"inflateBack()" functions.
</p>
</description>
<impact type="normal">
<p>
An attacker could exploit this vulnerability to launch a Denial of
Service attack on any application using the zlib library.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of zlib.
</p>
</workaround>
<resolution>
<p>
All zlib users should upgrade to the latest version:
</p>
<code>
# emerge sync
# emerge -pv &quot;&gt;=sys-libs/zlib-1.2.1-r3&quot;
# emerge &quot;&gt;=sys-libs/zlib-1.2.1-r3&quot;</code>
<p>
You should also run revdep-rebuild to rebuild any packages that depend
on older versions of zlib :
</p>
<code>
# revdep-rebuild</code>
</resolution>
<references>
<uri link="http://www.openpkg.org/security/OpenPKG-SA-2004.038-zlib.html">OpenPKG-SA-2004.038-zlib</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0797">CVE-2004-0797</uri>
</references>
<metadata tag="requester" timestamp="Thu, 26 Aug 2004 19:08:52 +0000">
jaervosz
</metadata>
<metadata tag="submitter" timestamp="Fri, 27 Aug 2004 05:21:24 +0000">
jaervosz
</metadata>
</glsa>