blob: c95a139d41f76c3f0122b7bd006c2cab4f0f8d1e [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200408-26">
<title>zlib: Denial of service vulnerability</title>
The zlib library contains a Denial of Service vulnerability.
<product type="ebuild">zlib</product>
<announced>August 27, 2004</announced>
<revised>May 22, 2006: 02</revised>
<package name="sys-libs/zlib" auto="yes" arch="*">
<unaffected range="ge">1.2.1-r3</unaffected>
<vulnerable range="le">1.2.1-r2</vulnerable>
zlib is a general-purpose data-compression library.
zlib contains a bug in the handling of errors in the "inflate()" and
"inflateBack()" functions.
<impact type="normal">
An attacker could exploit this vulnerability to launch a Denial of
Service attack on any application using the zlib library.
There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of zlib.
All zlib users should upgrade to the latest version:
# emerge sync
# emerge -pv &quot;&gt;=sys-libs/zlib-1.2.1-r3&quot;
# emerge &quot;&gt;=sys-libs/zlib-1.2.1-r3&quot;</code>
You should also run revdep-rebuild to rebuild any packages that depend
on older versions of zlib :
# revdep-rebuild</code>
<uri link="">OpenPKG-SA-2004.038-zlib</uri>
<uri link="">CVE-2004-0797</uri>
<metadata tag="requester" timestamp="Thu, 26 Aug 2004 19:08:52 +0000">
<metadata tag="submitter" timestamp="Fri, 27 Aug 2004 05:21:24 +0000">