blob: 6fb13f181afd6ea202a98aa50f32fcd6e31950cb [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200410-21">
<title>Apache 2, mod_ssl: Bypass of SSLCipherSuite directive</title>
In certain configurations, it can be possible to bypass restrictions set by
the "SSLCipherSuite" directive of mod_ssl.
<product type="ebuild">apache</product>
<announced>October 21, 2004</announced>
<revised>December 30, 2007: 02</revised>
<package name="www-servers/apache" auto="yes" arch="*">
<unaffected range="ge">2.0.52</unaffected>
<unaffected range="lt">2.0</unaffected>
<vulnerable range="lt">2.0.52</vulnerable>
<package name="net-www/mod_ssl" auto="yes" arch="*">
<unaffected range="ge">2.8.20</unaffected>
<vulnerable range="lt">2.8.20</vulnerable>
The Apache HTTP server is one of the most popular web servers on the
internet. mod_ssl provides SSL v2/v3 and TLS v1 support for Apache 1.3 and
is also included in Apache 2.
A flaw has been found in mod_ssl where the "SSLCipherSuite" directive could
be bypassed in certain configurations if it is used in a directory or
location context to restrict the set of allowed cipher suites.
<impact type="low">
A remote attacker could gain access to a location using any cipher suite
allowed by the server/virtual host configuration, disregarding the
restrictions by "SSLCipherSuite" for that location.
There is no known workaround at this time.
All Apache 2 users should upgrade to the latest version:
# emerge sync
# emerge -pv ">=www-servers/apache-2.0.52"
# emerge ">=www-servers/apache-2.0.52"</code>
All mod_ssl users should upgrade to the latest version:
# emerge sync
# emerge -pv ">=net-www/mod_ssl-2.8.20"
# emerge ">=net-www/mod_ssl-2.8.20"</code>
<uri link="">CAN-2004-0885</uri>
<uri link="">Apache HTTPD Bug 31505</uri>
<metadata tag="requester" timestamp="Fri, 8 Oct 2004 21:14:18 +0000">
<metadata tag="submitter" timestamp="Wed, 13 Oct 2004 20:52:28 +0000">
<metadata tag="bugReady" timestamp="Thu, 21 Oct 2004 04:34:44 +0000">