blob: 5912fea82f271677766018a4b5b53bd10bfe9924 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200411-18">
<title>Apache 2.0: Denial of Service by memory consumption</title>
A flaw in Apache 2.0 could allow a remote attacker to cause a Denial of
<product type="ebuild">apache</product>
<announced>November 10, 2004</announced>
<revised>December 30, 2007: 02</revised>
<package name="www-servers/apache" auto="yes" arch="*">
<unaffected range="ge">2.0.52-r1</unaffected>
<unaffected range="lt">2.0</unaffected>
<vulnerable range="lt">2.0.52-r1</vulnerable>
The Apache HTTP Server is one of the most popular web servers on the Internet.
Chintan Trivedi discovered a vulnerability in Apache httpd 2.0 that is caused by improper enforcing of the field length limit in the header-parsing code.
<impact type="normal">
By sending a large amount of specially-crafted HTTP GET requests a remote attacker could cause a Denial of Service of the targeted system.
There is no known workaround at this time.
All Apache 2.0 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.52-r1"</code>
<uri link="">CAN-2004-0942</uri>
<uri link="">Security vulnerabilities in Apache httpd 2.0</uri>
<metadata tag="submitter" timestamp="Mon, 8 Nov 2004 09:58:15 +0000">
<metadata tag="bugReady" timestamp="Tue, 9 Nov 2004 20:43:00 +0000">