blob: 5ffa1f68869702e258a837180abf8d02b1c41a36 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200412-24">
<title>Xpdf, GPdf: New integer overflows</title>
New integer overflows were discovered in Xpdf, potentially resulting in the
execution of arbitrary code. GPdf includes Xpdf code and therefore is
vulnerable to the same issues.
<product type="ebuild">Xpdf</product>
<announced>December 28, 2004</announced>
<revised>December 28, 2004: 01</revised>
<package name="app-text/xpdf" auto="yes" arch="*">
<unaffected range="ge">3.00-r7</unaffected>
<vulnerable range="le">3.00-r6</vulnerable>
<package name="app-text/gpdf" auto="yes" arch="*">
<unaffected range="ge">2.8.1-r1</unaffected>
<vulnerable range="le">2.8.1</vulnerable>
Xpdf is an open source viewer for Portable Document Format (PDF)
files. GPdf is a Gnome-based PDF viewer that includes some Xpdf code.
A new integer overflow issue was discovered in Xpdf's
Gfx::doImage() function.
<impact type="normal">
An attacker could entice an user to open a specially-crafted PDF
file, potentially resulting in execution of arbitrary code with the
rights of the user running Xpdf or GPdf.
There is no known workaround at this time.
All Xpdf users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=app-text/xpdf-3.00-r7&quot;</code>
All GPdf users should also upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=app-text/gpdf-2.8.1-r1&quot;</code>
<uri link="">CAN-2004-1125</uri>
<uri link=";type=vulnerabilities&amp;flashstatus=true">iDEFENSE Advisory</uri>
<metadata tag="submitter" timestamp="Tue, 28 Dec 2004 09:21:20 +0000">
<metadata tag="bugReady" timestamp="Tue, 28 Dec 2004 09:21:29 +0000">