blob: 7fd89abb95e5a5cb72a1fd34cc375231ce1c02d5 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200501-17">
<title>KPdf, KOffice: More vulnerabilities in included Xpdf</title>
KPdf and KOffice both include vulnerable Xpdf code to handle PDF files,
making them vulnerable to the execution of arbitrary code if a user is
enticed to view a malicious PDF file.
<product type="ebuild">kpdf, koffice</product>
<announced>January 11, 2005</announced>
<revised>January 12, 2005: 02</revised>
<package name="app-office/koffice" auto="yes" arch="*">
<unaffected range="ge">1.3.5-r1</unaffected>
<vulnerable range="lt">1.3.5-r1</vulnerable>
<package name="kde-base/kdegraphics" auto="yes" arch="*">
<unaffected range="ge">3.3.2-r1</unaffected>
<unaffected range="rge">3.2.3-r3</unaffected>
<vulnerable range="lt">3.3.2-r1</vulnerable>
KPdf is a KDE-based PDF viewer included in the kdegraphics package.
KOffice is an integrated office suite for KDE.
KPdf and KOffice both include Xpdf code to handle PDF files. Xpdf is
vulnerable to multiple new integer overflows, as described in GLSA
<impact type="normal">
An attacker could entice a user to open a specially-crafted PDF file,
potentially resulting in the execution of arbitrary code with the
rights of the user running the affected utility.
There is no known workaround at this time.
All KPdf users should upgrade to the latest version of kdegraphics:
# emerge --sync
# emerge --ask --oneshot --verbose kde-base/kdegraphics</code>
All KOffice users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose app-office/koffice</code>
<uri link="/security/en/glsa/glsa-200412-24.xml">GLSA 200412-24</uri>
<uri link="">CAN-2004-1125</uri>
<uri link="">KDE Security Advisory: kpdf Buffer Overflow Vulnerability</uri>
<uri link="">KOffice XPDF Integer Overflow 2</uri>
<metadata tag="submitter" timestamp="Wed, 5 Jan 2005 17:17:02 +0000">
<metadata tag="bugReady" timestamp="Tue, 11 Jan 2005 12:37:24 +0000">