blob: e26f0aa363ad3a3126df7d645413f2251c0d3ebd [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200506-12">
<title>MediaWiki: Cross-site scripting vulnerability</title>
MediaWiki is vulnerable to a cross-site scripting attack that could allow
arbitrary scripting code execution.
<product type="ebuild">mediawiki</product>
<announced>June 13, 2005</announced>
<revised>June 13, 2005: 01</revised>
<package name="www-apps/mediawiki" auto="yes" arch="*">
<unaffected range="ge">1.4.5</unaffected>
<unaffected range="rge">1.3.13</unaffected>
<vulnerable range="lt">1.4.5</vulnerable>
MediaWiki is a collaborative editing software, used by big
projects like Wikipedia.
MediaWiki incorrectly handles page template inclusions, rendering
it vulnerable to cross-site scripting attacks.
<impact type="low">
A remote attacker could exploit this vulnerability to inject
malicious script code that will be executed in a user's browser session
in the context of the vulnerable site.
There is no known workaround at this time.
All MediaWiki users should upgrade to the latest available
# emerge --sync
# emerge --ask --oneshot --verbose www-apps/mediawiki</code>
<uri link="">MediaWiki 1.4.5 Release Notes</uri>
<metadata tag="requester" timestamp="Fri, 10 Jun 2005 11:34:01 +0000">
<metadata tag="bugReady" timestamp="Fri, 10 Jun 2005 11:34:36 +0000">
<metadata tag="submitter" timestamp="Sat, 11 Jun 2005 12:24:08 +0000">