blob: 7735e3d01af10ebd0f96ab6c3f12856bfd91942f [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200506-19">
<title>SquirrelMail: Several XSS vulnerabilities</title>
Squirrelmail is vulnerable to several cross-site scripting vulnerabilities
which could lead to a compromise of webmail accounts.
<product type="ebuild">SquirrelMail</product>
<announced>June 21, 2005</announced>
<revised>June 21, 2005: 01</revised>
<package name="mail-client/squirrelmail" auto="yes" arch="*">
<unaffected range="ge">1.4.4</unaffected>
<unaffected range="lt">1.4.0</unaffected>
<vulnerable range="lt">1.4.4</vulnerable>
SquirrelMail is a webmail package written in PHP. It supports IMAP
and SMTP protocols.
SquirrelMail is vulnerable to several cross-site scripting issues,
most reported by Martijn Brinkers.
<impact type="low">
By enticing a user to read a specially-crafted e-mail or using a
manipulated URL, an attacker can execute arbitrary scripts running in
the context of the victim's browser. This could lead to a compromise of
the user's webmail account, cookie theft, etc.
There is no known workaround at this time.
All SquirrelMail users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=mail-client/squirrelmail-1.4.4&quot;</code>
Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.
<uri link="">SquirrelMail Advisory</uri>
<uri link="">CAN-2005-1769</uri>
<metadata tag="submitter" timestamp="Sun, 19 Jun 2005 19:26:13 +0000">
<metadata tag="bugReady" timestamp="Mon, 20 Jun 2005 17:48:27 +0000">