blob: 076ef7d476bdef1cbd11d6c6b3414d3821fea318 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200507-18">
<title>MediaWiki: Cross-site scripting vulnerability</title>
<synopsis>
MediaWiki is vulnerable to a cross-site scripting attack that could allow
arbitrary JavaScript code execution.
</synopsis>
<product type="ebuild">mediawiki</product>
<announced>July 20, 2005</announced>
<revised>August 11, 2005: 03</revised>
<bug>99132</bug>
<access>remote</access>
<affected>
<package name="www-apps/mediawiki" auto="yes" arch="*">
<unaffected range="ge">1.4.6</unaffected>
<vulnerable range="lt">1.4.6</vulnerable>
</package>
</affected>
<background>
<p>
MediaWiki is a collaborative editing software, used by big projects
like Wikipedia.
</p>
</background>
<description>
<p>
MediaWiki fails to escape a parameter in the page move template
correctly.
</p>
</description>
<impact type="low">
<p>
By enticing a user to visit a specially crafted URL, a remote attacker
could exploit this vulnerability to inject malicious JavaScript code
that will be executed in a user's browser session in the context of the
vulnerable site.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All MediaWiki users should upgrade to the latest available version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-apps/mediawiki-1.4.7&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2396">CAN-2005-2396</uri>
<uri link="http://sourceforge.net/project/shownotes.php?release_id=342530">MediaWiki Release Notes</uri>
</references>
<metadata tag="requester" timestamp="Mon, 18 Jul 2005 07:34:17 +0000">
koon
</metadata>
<metadata tag="bugReady" timestamp="Mon, 18 Jul 2005 07:34:40 +0000">
koon
</metadata>
<metadata tag="submitter" timestamp="Mon, 18 Jul 2005 07:59:14 +0000">
DerCorny
</metadata>
</glsa>