blob: 076ef7d476bdef1cbd11d6c6b3414d3821fea318 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200507-18">
<title>MediaWiki: Cross-site scripting vulnerability</title>
MediaWiki is vulnerable to a cross-site scripting attack that could allow
arbitrary JavaScript code execution.
<product type="ebuild">mediawiki</product>
<announced>July 20, 2005</announced>
<revised>August 11, 2005: 03</revised>
<package name="www-apps/mediawiki" auto="yes" arch="*">
<unaffected range="ge">1.4.6</unaffected>
<vulnerable range="lt">1.4.6</vulnerable>
MediaWiki is a collaborative editing software, used by big projects
like Wikipedia.
MediaWiki fails to escape a parameter in the page move template
<impact type="low">
By enticing a user to visit a specially crafted URL, a remote attacker
could exploit this vulnerability to inject malicious JavaScript code
that will be executed in a user's browser session in the context of the
vulnerable site.
There is no known workaround at this time.
All MediaWiki users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-apps/mediawiki-1.4.7&quot;</code>
<uri link="">CAN-2005-2396</uri>
<uri link="">MediaWiki Release Notes</uri>
<metadata tag="requester" timestamp="Mon, 18 Jul 2005 07:34:17 +0000">
<metadata tag="bugReady" timestamp="Mon, 18 Jul 2005 07:34:40 +0000">
<metadata tag="submitter" timestamp="Mon, 18 Jul 2005 07:59:14 +0000">