blob: d775a2811b42040062bbe712c01ff4f7e8877ff2 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200508-15">
<title>Apache 2.0: Denial of Service vulnerability</title>
A bug in Apache may allow a remote attacker to perform a Denial of Service
<product type="ebuild">apache</product>
<announced>August 25, 2005</announced>
<revised>December 30, 2007: 03</revised>
<package name="www-servers/apache" auto="yes" arch="*">
<unaffected range="ge">2.0.54-r9</unaffected>
<unaffected range="lt">2.0</unaffected>
<vulnerable range="lt">2.0.54-r9</vulnerable>
The Apache HTTP Server Project is a featureful, freely-available HTTP
(Web) server.
Filip Sneppe discovered that Apache improperly handles byterange
requests to CGI scripts.
<impact type="normal">
A remote attacker may access vulnerable scripts in a malicious way,
exhausting all RAM and swap space on the server, resulting in a Denial
of Service of the Apache server.
There is no known workaround at this time.
All apache users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-servers/apache-2.0.54-r9&quot;</code>
<uri link="">ASF Bugzilla Bug 29962</uri>
<uri link="">CVE-2005-2728</uri>
<metadata tag="requester" timestamp="Mon, 22 Aug 2005 07:26:08 +0000">
<metadata tag="bugReady" timestamp="Mon, 22 Aug 2005 07:47:26 +0000">
<metadata tag="submitter" timestamp="Wed, 24 Aug 2005 00:58:46 +0000">