blob: d775a2811b42040062bbe712c01ff4f7e8877ff2 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200508-15">
<title>Apache 2.0: Denial of Service vulnerability</title>
<synopsis>
A bug in Apache may allow a remote attacker to perform a Denial of Service
attack.
</synopsis>
<product type="ebuild">apache</product>
<announced>August 25, 2005</announced>
<revised>December 30, 2007: 03</revised>
<bug>102991</bug>
<access>remote</access>
<affected>
<package name="www-servers/apache" auto="yes" arch="*">
<unaffected range="ge">2.0.54-r9</unaffected>
<unaffected range="lt">2.0</unaffected>
<vulnerable range="lt">2.0.54-r9</vulnerable>
</package>
</affected>
<background>
<p>
The Apache HTTP Server Project is a featureful, freely-available HTTP
(Web) server.
</p>
</background>
<description>
<p>
Filip Sneppe discovered that Apache improperly handles byterange
requests to CGI scripts.
</p>
</description>
<impact type="normal">
<p>
A remote attacker may access vulnerable scripts in a malicious way,
exhausting all RAM and swap space on the server, resulting in a Denial
of Service of the Apache server.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All apache users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-servers/apache-2.0.54-r9&quot;</code>
</resolution>
<references>
<uri link="http://issues.apache.org/bugzilla/show_bug.cgi?id=29962">ASF Bugzilla Bug 29962</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2728">CVE-2005-2728</uri>
</references>
<metadata tag="requester" timestamp="Mon, 22 Aug 2005 07:26:08 +0000">
DerCorny
</metadata>
<metadata tag="bugReady" timestamp="Mon, 22 Aug 2005 07:47:26 +0000">
koon
</metadata>
<metadata tag="submitter" timestamp="Wed, 24 Aug 2005 00:58:46 +0000">
adir
</metadata>
</glsa>