blob: 2499a5735b404d161d8c47a7cf5bea58aadb7cb9 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200509-12">
<title>Apache, mod_ssl: Multiple vulnerabilities</title>
<synopsis>
mod_ssl and Apache are vulnerable to a restriction bypass and a potential
local privilege escalation.
</synopsis>
<product type="ebuild">Apache</product>
<announced>September 19, 2005</announced>
<revised>December 30, 2007: 03</revised>
<bug>103554</bug>
<bug>104807</bug>
<access>remote and local</access>
<affected>
<package name="net-www/mod_ssl" auto="yes" arch="*">
<unaffected range="ge">2.8.24</unaffected>
<vulnerable range="lt">2.8.24</vulnerable>
</package>
<package name="www-servers/apache" auto="yes" arch="*">
<unaffected range="ge">2.0.54-r15</unaffected>
<unaffected range="lt">2</unaffected>
<vulnerable range="lt">2.0.54-r15</vulnerable>
</package>
</affected>
<background>
<p>
The Apache HTTP server is one of the most popular web servers on the
Internet. mod_ssl provides SSL v2/v3 and TLS v1 support for Apache 1.3
and is also included in Apache 2.
</p>
</background>
<description>
<p>
mod_ssl contains a security issue when "SSLVerifyClient optional" is
configured in the global virtual host configuration (CAN-2005-2700).
Also, Apache's httpd includes a PCRE library, which makes it vulnerable
to an integer overflow (CAN-2005-2491).
</p>
</description>
<impact type="normal">
<p>
Under a specific configuration, mod_ssl does not properly enforce the
client-based certificate authentication directive, "SSLVerifyClient
require", in a per-location context, which could be potentially used by
a remote attacker to bypass some restrictions. By creating a specially
crafted ".htaccess" file, a local attacker could possibly exploit
Apache's vulnerability, which would result in a local privilege
escalation.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All mod_ssl users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=net-www/mod_ssl-2.8.24&quot;</code>
<p>
All Apache 2 users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-servers/apache-2.0.54-r15&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2491">CAN-2005-2491</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2700">CAN-2005-2700</uri>
</references>
<metadata tag="requester" timestamp="Sun, 11 Sep 2005 10:15:26 +0000">
koon
</metadata>
<metadata tag="bugReady" timestamp="Fri, 16 Sep 2005 16:41:43 +0000">
koon
</metadata>
<metadata tag="submitter" timestamp="Sat, 17 Sep 2005 14:36:28 +0000">
formula7
</metadata>
</glsa>