blob: 17a8018948366b9bd264d8750ba17e30589f3fd5 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200601-05">
<title>mod_auth_pgsql: Multiple format string vulnerabilities</title>
Format string vulnerabilities in mod_auth_pgsql may lead to the execution
of arbitrary code.
<product type="ebuild">mod_auth_pgsql</product>
<announced>January 10, 2006</announced>
<revised>December 30, 2007: 03</revised>
<package name="www-apache/mod_auth_pgsql" auto="yes" arch="*">
<unaffected range="ge">2.0.3</unaffected>
<unaffected range="lt">1.0.0</unaffected>
<vulnerable range="lt">2.0.3</vulnerable>
mod_auth_pgsql is an Apache2 module that allows user authentication
against a PostgreSQL database.
The error logging functions of mod_auth_pgsql fail to validate certain
strings before passing them to syslog, resulting in format string
<impact type="high">
An unauthenticated remote attacker could exploit these vulnerabilities
to execute arbitrary code with the rights of the user running the
Apache2 server by sending specially crafted login names.
There is no known workaround at this time.
All mod_auth_pgsql users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-apache/mod_auth_pgsql-2.0.3&quot;</code>
<uri link="">CVE-2005-3656</uri>
<uri link="">FrSIRT ADV-2006-0070</uri>
<metadata tag="requester" timestamp="Sun, 08 Jan 2006 17:42:51 +0000">
<metadata tag="bugReady" timestamp="Sun, 08 Jan 2006 17:43:17 +0000">
<metadata tag="submitter" timestamp="Mon, 09 Jan 2006 09:56:56 +0000">