blob: e9a385c4a1ce57562645f665fd3d495789aa9f41 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200605-14">
<title>libextractor: Two heap-based buffer overflows</title>
libextractor is vulnerable to two heap overflow vulnerabilities which could
lead to the execution of arbitrary code.
<product type="ebuild">libextractor</product>
<announced>May 21, 2006</announced>
<revised>May 21, 2006: 01</revised>
<package name="media-libs/libextractor" auto="yes" arch="*">
<unaffected range="ge">0.5.14</unaffected>
<vulnerable range="lt">0.5.14</vulnerable>
libextractor is a library used to extract metadata from arbitrary
Luigi Auriemma has found two heap-based buffer overflows in
libextractor 0.5.13 and earlier: one of them occurs in the
asf_read_header function in the ASF plugin, and the other occurs in the
parse_trak_atom function in the Qt plugin.
<impact type="normal">
By enticing a user to open a malformed file using an application
that employs libextractor and its ASF or Qt plugins, an attacker could
execute arbitrary code in the context of the application running the
affected library.
There is no known workaround at this time.
All libextractor users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=media-libs/libextractor-0.5.14&quot;</code>
<uri link="">CVE-2006-2458</uri>
<uri link="">Original advisory</uri>
<metadata tag="requester" timestamp="Fri, 19 May 2006 13:49:39 +0000">
<metadata tag="bugReady" timestamp="Fri, 19 May 2006 13:49:51 +0000">
<metadata tag="submitter" timestamp="Fri, 19 May 2006 16:16:14 +0000">